poj-1152 An Easy Problem!

news/2024/7/11 1:54:26 标签: integer, input, output, system, each, file

题目链接:http://poj.org/problem?id=1152

An Easy Problem!
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 7708 Accepted: 1847

Description

Have you heard the fact "The base of every normal number system is 10" ? Of course, I am not talking about number systems like Stern Brockot Number System. This problem has nothing to do with this fact but may have some similarity. 

You will be given an N based integer number R and you are given the guaranty that R is divisible by (N-1). You will have to print the smallest possible value for N. The range for N is 2 <= N <= 62 and the digit symbols for 62 based number is (0..9 and A..Z and a..z). Similarly, the digit symbols for 61 based number system is (0..9 and A..Z and a..y) and so on.

Input

Each line in the input will contain an integer (as defined in mathematics) number of any integer base (2..62). You will have to determine what is the smallest possible base of that number for the given conditions. No invalid number will be given as input. The largest size of the input file will be 32KB.

Output

If number with such condition is not possible output the line "such number is impossible!" For each line of input there will be only a single line of output. The output will always be in decimal number system.

Sample Input

3
5
A

Sample Output

4
6
11
题意: 正如题目所说,一个简单的问题!输入一个2-62进制的数字,即假设这个数字是n进制,则这个数x%(n-1)==0。
好吧,既然如此简单,就不废话了。。。。
#include<iostream>
#include<stdio.h>
#include<string.h>
using namespace std;
char a[100000];
int main()
{
    int i,s,len,max;
    bool d;
    while(scanf("%s",a)!=EOF)
    {
        len=strlen(a);
        s=0;
        max=0;               //max记录所能代表的最小进制数(比如数字里面有B,则这个进制至少也是12吧。。。)
        for(i=0;i<len;i++)             //接下来的过程,不要怀疑.经过验证了的
        {	//(如果这个n进制的数能取余n-1等于0,则这个数的各个位数相加也要能取余n-1等于0,这样问题变简单咯)[这个很容易证明的,不妨试试]
            if (a[i]>='0'&&a[i]<='9')
            {
                if (a[i]-'0'>max) max=a[i]-'0';
                s=s+a[i]-'0';
            }
            if (a[i]>='a'&&a[i]<='z')
            {
                if (a[i]-'a'+36>max) max=a[i]-'a'+36;
                s=s+a[i]-'a'+36;
            }
            if (a[i]>='A'&&a[i]<='Z')
            {
                if (a[i]-'A'+10>max) max=a[i]-'A'+10;
                s=s+a[i]-'A'+10;
            }
        }
        d=false;
        for(i=2;i<=62;i++)
          if (s%(i-1)==0&&max<i) {d=true;break;}
        if (d) printf("%d\n",i);
        else
        printf("such number is impossible!\n");
    }
    return 0;
}




http://www.niftyadmin.cn/n/870077.html

相关文章

poj-1730 Perfect Pth Powers

题目链接&#xff1a;http://poj.org/problem?id1730 Perfect Pth PowersTime Limit: 1000MS Memory Limit: 10000KTotal Submissions: 13099 Accepted: 2990 Description We say that x is a perfect square if, for some integer b, x b2. Similarly, x is a perfect cube …

poj-2262 Goldbach's Conjecture

题目链接&#xff1a;http://poj.org/problem?id2262 Goldbachs ConjectureTime Limit: 1000MS Memory Limit: 65536KTotal Submissions: 28046 Accepted: 10797 Description In 1742, Christian Goldbach, a German amateur mathematician, sent a letter to Leonhard Euler …

poj-3258 River Hopscotch

题目链接&#xff1a;http://poj.org/problem?id3258 River HopscotchTime Limit: 2000MS Memory Limit: 65536KTotal Submissions: 3829 Accepted: 1649 Description Every year the cows hold an event featuring a peculiar version of hopscotch that involves carefully …

poj-1183 反正切函数的应用

题目链接&#xff1a;http://poj.org/problem?id1183 反正切函数的应用Time Limit: 1000MS Memory Limit: 10000KTotal Submissions: 12382 Accepted: 4479 Description 反正切函数可展开成无穷级数&#xff0c;有如下公式 (其中0 < x < 1) 公式(1) 使用反正切函数计算P…

poj-2388 Who's in the Middle

题目连接&#xff1a;http://poj.org/problem?id2388 Whos in the MiddleTime Limit: 1000MS Memory Limit: 65536KTotal Submissions: 22478 Accepted: 12864 Description FJ is surveying his herd to find the most average cow. He wants to know how much milk this medi…

最大公约数、最小公倍数

最大公约数&#xff1a; int func(int m,int n){return (!n)?m:func(n,m%n);}m和n的最大公约数为k&#xff0c;则m和n的最小公倍数则是k*(m%k)*(n%k)。

十进制-十六进制

十进制-十六进制 Description 把十进制整数转换为十六进制&#xff0c;格式为0x开头&#xff0c;10~15由大写字母A~F表示。 Input 每行一个整数x&#xff0c;0< x < 2^31。 Output 每行输出对应的八位十六进制整数&#xff0c;包括前导0。 Sample Input 0 1023 Sample …

张利华:夺命的中国IT互联网行业

网上的一篇文章&#xff0c;写的很好&#xff0c;拿过来了。 张利华&#xff1a;夺命的中国IT互联网行业 --- 我们每隔一段时间就会在网上祭奠一位因病去世的年轻IT人&#xff0c;真不希望这个现象继续。紫光软件集团总裁、38岁的智播客创始…